Jakarta JSON Processing - 2.2

JavaDoc Assertion Detail

TotalsTotalActiveDeprecatedRemoved
# of Assertions4122820130
# of Required Assertions4122820130
# of Optional Assertions0000
IDReturnMethod/FieldDescriptionRequiredDeprecatedTestable
JSONP:JAVADOC:6JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( JsonValue )Adds a value to the array.truetrue
JSONP:JAVADOC:8JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( String )Adds a value to the array as a JsonString.truetrue
JSONP:JAVADOC:10JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( BigDecimal )Adds a value to the array as a JsonNumber.truetrue
JSONP:JAVADOC:12JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( BigInteger )Adds a value to the array as a JsonNumber.truetrue
JSONP:JAVADOC:14JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int )Adds a value to the array as a JsonNumber.truetrue
JSONP:JAVADOC:16JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( long )Adds a value to the array as a JsonNumber.truetrue
JSONP:JAVADOC:18JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( double )Adds a value to the array as a JsonNumber.truetrue
JSONP:JAVADOC:21JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( boolean )Adds a JsonValue#TRUE or JsonValue#FALSE value to the array.truetrue
JSONP:JAVADOC:25JsonArrayBuilderjakarta.json.JsonArrayBuilder.addNullAdds a JsonValue#NULL value to the array.truetrue
JSONP:JAVADOC:37JsonExceptionjakarta.json.JsonException.JsonException ( String )Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to #initCause.truetrue
JSONP:JAVADOC:38JsonExceptionjakarta.json.JsonException.JsonException ( String , Throwable )Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.truetrue
JSONP:JAVADOC:40BigDecimaljakarta.json.JsonNumber.bigDecimalValueReturns this JSON number as a BigDecimal object.truetrue
JSONP:JAVADOC:41BigIntegerjakarta.json.JsonNumber.bigIntegerValueReturns this JSON number as a BigInteger object. This is a a convenience method for bigDecimalValue().toBigInteger(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.truetrue
JSONP:JAVADOC:42BigIntegerjakarta.json.JsonNumber.bigIntegerValueExactReturns this JSON number as a BigInteger object. This is a convenience method for bigDecimalValue().toBigIntegerExact().truetrue
JSONP:JAVADOC:44doublejakarta.json.JsonNumber.doubleValueReturns this JSON number as a double. This is a a convenience method for bigDecimalValue().doubleValue(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.truetrue
JSONP:JAVADOC:45intjakarta.json.JsonNumber.intValueReturns this JSON number as an int. Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.truetrue
JSONP:JAVADOC:46intjakarta.json.JsonNumber.intValueExactReturns this JSON number as an int.truetrue
JSONP:JAVADOC:48longjakarta.json.JsonNumber.longValueReturns this JSON number as a long. Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign.truetrue
JSONP:JAVADOC:49longjakarta.json.JsonNumber.longValueExactReturns this JSON number as a long.truetrue
JSONP:JAVADOC:51booleanjakarta.json.JsonNumber.isIntegralReturns true if this JSON number is a integral number. This method semantics are defined using bigDecimalValue().scale(). If the scale is zero, then it is considered integral type. This integral type information can be used to invoke an appropriate accessor method to obtain a numeric value as in the following example: JsonNumber num = ... if (num.isIntegral()) { num.longValue(); // or other methods to get integral value } else { num.doubleValue(); // or other methods to get decimal number value }truetrue
JSONP:JAVADOC:58JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , JsonValue )Adds a name/JsonValue pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:61JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , String )Adds a name/JsonString pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:64JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , BigInteger )Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:67JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , BigDecimal )Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:70JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , int )Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:73JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , long )Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:76JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , double )Adds a name/JsonNumber pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:80JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , boolean )Adds a name/JsonValue#TRUE or name/JsonValue#FALSE pair to the JSON object associated with this object builder. If the object contains a mapping for the specified name, this method replaces the old value with the specified value.truetrue
JSONP:JAVADOC:86JsonObjectBuilderjakarta.json.JsonObjectBuilder.addNull ( String )Adds a name/JsonValue#NULL pair to the JSON object associated with this object builder where the value is null. If the object contains a mapping for the specified name, this method replaces the old value with null.truetrue
JSONP:JAVADOC:96voidjakarta.json.JsonReader.closeCloses this reader and frees any resources associated with the reader. This method closes the underlying input source.truetrue
JSONP:JAVADOC:97JsonReaderjakarta.json.Json.createReader ( Reader )Creates a JSON reader from a character stream.truetrue
JSONP:JAVADOC:101Stringjakarta.json.JsonString.getStringReturns the JSON string value.truetrue
JSONP:JAVADOC:102ValueTypejakarta.json.JsonValue.getValueTypeReturns the value type of this JSON value.truetrue
JSONP:JAVADOC:103ValueTypejakarta.json.JsonValue.ValueType.valueOf ( String )truetrue
JSONP:JAVADOC:104ValueType[]jakarta.json.JsonValue.ValueType.valuestruetrue
JSONP:JAVADOC:105voidjakarta.json.JsonWriter.closetruetrue
JSONP:JAVADOC:106JsonWriterjakarta.json.Json.createWriter ( Writer )Creates a JSON writer to write a JSON JsonObject object or JsonArray array structure to the specified character stream.truetrue
JSONP:JAVADOC:107voidjakarta.json.JsonWriter.writeArray ( JsonArray )Writes the specified JSON JsonArray array to the output source. This method needs to be called only once for a writer instance.truetrue
JSONP:JAVADOC:110voidjakarta.json.JsonWriter.writeObject ( JsonObject )Writes the specified JSON JsonObject object to the output source. This method needs to be called only once for a writer instance.truetrue
JSONP:JAVADOC:115voidjakarta.json.stream.JsonGenerator.closeCloses this generator and frees any resources associated with it. This method closes the underlying output source.truetrue
JSONP:JAVADOC:117voidjakarta.json.stream.JsonParser.closeCloses this parser and frees any resources associated with the parser. This method closes the underlying input source.truetrue
JSONP:JAVADOC:120booleanjakarta.json.stream.JsonParser.isIntegralNumberReturns true if the JSON number at the current parser state is a integral number. A BigDecimal may be used to store the value internally and this method semantics are defined using its scale(). If the scale is zero, then it is considered integral type. This integral type information can be used to invoke an appropriate accessor method to obtain a numeric value as in the following example: JsonParser parser = ... if (parser.isIntegralNumber()) { parser.getInt(); // or other methods to get integral value } else { parser.getBigDecimal(); }truetrue
JSONP:JAVADOC:122Stringjakarta.json.stream.JsonParser.getStringReturns a String for the name in a name/value pair, for a string value or a number value. This method should only be called when the parser state is Event#KEY_NAME, Event#VALUE_STRING, or Event#VALUE_NUMBER.truetrue
JSONP:JAVADOC:128Eventjakarta.json.stream.JsonParser.Event.valueOf ( String )truetrue
JSONP:JAVADOC:129Event[]jakarta.json.stream.JsonParser.Event.valuestruetrue
JSONP:JAVADOC:131JsonGeneratorjakarta.json.Json.createGenerator ( Writer )Creates a JSON generator for writing JSON to a character stream.truetrue
JSONP:JAVADOC:133JsonParserjakarta.json.Json.createParser ( Reader )Creates a JSON parser from a character stream.truetrue
JSONP:JAVADOC:144JsonGeneratorjakarta.json.spi.JsonProvider.createGenerator ( Writer )Creates a JSON generator for writing JSON text to a character stream.truetrue
JSONP:JAVADOC:146JsonParserjakarta.json.spi.JsonProvider.createParser ( Reader )Creates a JSON parser from a character stream.truetrue
JSONP:JAVADOC:152JsonProviderjakarta.json.spi.JsonProvider.providerCreates a JSON provider object. The provider is loaded using the ServiceLoader#load(Class) method. If there are no available service providers, this method returns the default service provider. Users are recommended to cache the result of this method.truetrue
JSONP:JAVADOC:162JsonGeneratorjakarta.json.stream.JsonGeneratorFactory.createGenerator ( Writer )Creates a JSON generator to write JSON text to a character stream. The generator is configured with the factory configuration.truetrue
JSONP:JAVADOC:163JsonGeneratorjakarta.json.stream.JsonGeneratorFactory.createGenerator ( OutputStream , Charset )Creates a JSON generator to write JSON text to a byte stream. Characters written to the stream are encoded into bytes using the specified charset. The generator is configured with the factory's configuration.truetrue
JSONP:JAVADOC:164JsonParserjakarta.json.stream.JsonParserFactory.createParser ( Reader )Creates a JSON parser from a character stream.truetrue
JSONP:JAVADOC:165JsonParserjakarta.json.stream.JsonParserFactory.createParser ( InputStream )Creates a JSON parser from the specified byte stream. The character encoding of the stream is determined as specified in RFC 7159.truetrue
JSONP:JAVADOC:166JsonParserjakarta.json.stream.JsonParserFactory.createParser ( JsonObject )Creates a JSON parser from the specified JSON object.truetrue
JSONP:JAVADOC:167JsonParserjakarta.json.stream.JsonParserFactory.createParser ( JsonArray )Creates a JSON parser from the specified JSON array.truetrue
JSONP:JAVADOC:168JsonGeneratorjakarta.json.Json.createGenerator ( OutputStream )Creates a JSON generator for writing JSON to a byte stream.truetrue
JSONP:JAVADOC:172JsonParserjakarta.json.Json.createParser ( InputStream )Creates a JSON parser from a byte stream. The character encoding of the stream is determined as specified in RFC 7159.truetrue
JSONP:JAVADOC:178JsonReaderjakarta.json.Json.createReader ( InputStream )Creates a JSON reader from a byte stream. The character encoding of the stream is determined as described in RFC 7159.truetrue
JSONP:JAVADOC:181JsonStructurejakarta.json.JsonReader.readReturns a JSON array or object that is represented in the input source. This method needs to be called only once for a reader instance.truetrue
JSONP:JAVADOC:184JsonArrayjakarta.json.JsonReader.readArrayReturns a JSON array that is represented in the input source. This method needs to be called only once for a reader instance.truetrue
JSONP:JAVADOC:185JsonObjectjakarta.json.JsonReader.readObjectReturns a JSON object that is represented in the input source. This method needs to be called only once for a reader instance.truetrue
JSONP:JAVADOC:187JsonWriterjakarta.json.Json.createWriter ( OutputStream )Creates a JSON writer to write a JSON JsonObject object or JsonArray array structure to the specified byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding.truetrue
JSONP:JAVADOC:191voidjakarta.json.JsonWriter.write ( JsonStructure )Writes the specified JSON JsonObject object or JsonArray array to the output source. This method needs to be called only once for a writer instance.truetrue
JSONP:JAVADOC:192JsonGeneratorjakarta.json.spi.JsonProvider.createGenerator ( OutputStream )Creates a JSON generator for writing JSON text to a byte stream.truetrue
JSONP:JAVADOC:196JsonParserjakarta.json.spi.JsonProvider.createParser ( InputStream )Creates a JSON parser from the specified byte stream. The character encoding of the stream is determined as defined in RFC 7159 .truetrue
JSONP:JAVADOC:200JsonGeneratorjakarta.json.stream.JsonGeneratorFactory.createGenerator ( OutputStream )Creates a JSON generator to write JSON text to a byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding. The generator is configured with the factory's configuration.truetrue
JSONP:JAVADOC:201JsonParserjakarta.json.stream.JsonParserFactory.createParser ( InputStream , Charset )Creates a JSON parser from the specified byte stream. The bytes of the stream are decoded to characters using the specified charset.truetrue
JSONP:JAVADOC:215Stringjakarta.json.JsonNumber.toStringReturns a JSON text representation of the JSON number. The representation is equivalent to BigDecimal#toString().truetrue
JSONP:JAVADOC:235BigDecimaljakarta.json.stream.JsonParser.getBigDecimalReturns a JSON number as a BigDecimal. The BigDecimal is created using new BigDecimal(getString()). This method should only called when the parser state is Event#VALUE_NUMBER.truetrue
JSONP:JAVADOC:237intjakarta.json.stream.JsonParser.getIntReturns a JSON number as an integer. The returned value is equal to new BigDecimal(getString()).intValue(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign. This method should only be called when the parser state is Event#VALUE_NUMBER.truetrue
JSONP:JAVADOC:239longjakarta.json.stream.JsonParser.getLongReturns a JSON number as a long. The returned value is equal to new BigDecimal(getString()).longValue(). Note that this conversion can lose information about the overall magnitude and precision of the number value as well as return a result with the opposite sign. This method is only called when the parser state is Event#VALUE_NUMBER.truetrue
JSONP:JAVADOC:250booleanjakarta.json.JsonNumber.equals ( Object )Compares the specified object with this JsonNumber object for equality. Returns true if and only if the type of the specified object is also JsonNumber and their #bigDecimalValue() objects are equaltruetrue
JSONP:JAVADOC:251intjakarta.json.JsonNumber.hashCodeReturns the hash code value for this JsonNumber object. The hash code of a JsonNumber object is defined as the hash code of its #bigDecimalValue() object.truetrue
JSONP:JAVADOC:254booleanjakarta.json.JsonString.equals ( Object )Compares the specified object with this JsonString for equality. Returns true if and only if the specified object is also a JsonString, and their #getString() objects are equal.truetrue
JSONP:JAVADOC:255intjakarta.json.JsonString.hashCodeReturns the hash code value for this JsonString object. The hash code of a JsonString object is defined to be its #getString() object's hash code.truetrue
JSONP:JAVADOC:262intjakarta.json.JsonArray.getInt ( int )A convenience method for getJsonNumber(index).intValue().truetrue
JSONP:JAVADOC:263Stringjakarta.json.JsonArray.getString ( int )A convenience method for getJsonString(index).getString().truetrue
JSONP:JAVADOC:264intjakarta.json.JsonObject.getInt ( String )A convenience method for getJsonNumber(name).intValue()truetrue
JSONP:JAVADOC:265Stringjakarta.json.JsonObject.getString ( String )A convenience method for getJsonString(name).getString()truetrue
JSONP:JAVADOC:278JsonGenerationExceptionjakarta.json.stream.JsonGenerationException.JsonGenerationException ( String )Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to #initCause.truetrue
JSONP:JAVADOC:279JsonGenerationExceptionjakarta.json.stream.JsonGenerationException.JsonGenerationException ( String , Throwable )Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.truetrue
JSONP:JAVADOC:285JsonParsingExceptionjakarta.json.stream.JsonParsingException.JsonParsingException ( String , JsonLocation )Constructs a new runtime exception with the specified detail message. The cause is not initialized, and may subsequently be initialized by a call to #initCause.truetrue
JSONP:JAVADOC:286JsonParsingExceptionjakarta.json.stream.JsonParsingException.JsonParsingException ( String , Throwable , JsonLocation )Constructs a new runtime exception with the specified detail message and cause. Note that the detail message associated with cause is not automatically incorporated in this runtime exception's detail message.truetrue
JSONP:JAVADOC:288Stringjakarta.json.JsonValue.toStringReturns JSON text for this JSON value.truetrue
JSONP:JAVADOC:289JsonGeneratorjakarta.json.stream.JsonGenerator.writeEndWrites the end of the current context. If the current context is an array context, this method writes the end-of-array character (‘]’). If the current context is an object context, this method writes the end-of-object character (‘}’). After writing the end of the current context, the parent context becomes the new current context. If parent context is field context, it is closed.truetrue
JSONP:JAVADOC:291voidjakarta.json.stream.JsonGenerator.flushFlushes the underlying output source. If the generator has saved any characters in a buffer, writes them immediately to the underlying output source before flushing it.truetrue
JSONP:JAVADOC:292JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , JsonValue )Writes a JSON name/value pair in the current object context.truetrue
JSONP:JAVADOC:295JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , String )Writes a JSON name/string value pair in the current object context. The specified value is written as JSON string value.truetrue
JSONP:JAVADOC:298JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , BigInteger )Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string new BigDecimal(value).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:301JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , BigDecimal )Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The specified value's toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:304JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , int )Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string new BigDecimal(value).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:307JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , long )Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string new BigDecimal(value).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:310JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , double )Writes a JSON name/number value pair in the current object context. The specified value is written as a JSON number value. The string BigDecimal.valueOf(double).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:314JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String , boolean )Writes a JSON name/boolean value pair in the current object context. If value is true, it writes the JSON true value, otherwise it writes the JSON false value.truetrue
JSONP:JAVADOC:317JsonGeneratorjakarta.json.stream.JsonGenerator.write ( JsonValue )Writes the specified value as a JSON value within the current array, field or root context.truetrue
JSONP:JAVADOC:319JsonGeneratorjakarta.json.stream.JsonGenerator.write ( String )Writes the specified value as a JSON string value within the current array, field or root context.truetrue
JSONP:JAVADOC:321JsonGeneratorjakarta.json.stream.JsonGenerator.write ( BigDecimal )Writes the specified value as a JSON number value within the current array, field or root context. The specified value's toString() is used as the the text value for writing.truetrue
JSONP:JAVADOC:323JsonGeneratorjakarta.json.stream.JsonGenerator.write ( BigInteger )Writes the specified value as a JSON number value within the current array, field or root context. The string new BigDecimal(value).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:325JsonGeneratorjakarta.json.stream.JsonGenerator.write ( int )Writes the specified value as a JSON number value within the current array, field or root context. The string new BigDecimal(value).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:327JsonGeneratorjakarta.json.stream.JsonGenerator.write ( long )Writes the specified value as a JSON number value within the current array, field or root context. The string new BigDecimal(value).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:329JsonGeneratorjakarta.json.stream.JsonGenerator.write ( double )Writes the specified value as a JSON number value within the current array, field or root context. The string BigDecimal.valueOf(value).toString() is used as the text value for writing.truetrue
JSONP:JAVADOC:332JsonGeneratorjakarta.json.stream.JsonGenerator.write ( boolean )Writes a JSON true or false value within the current array, field or root context. If value is true, this method writes the JSON true value, otherwise it writes the JSON false value.truetrue
JSONP:JAVADOC:334JsonGeneratorjakarta.json.stream.JsonGenerator.writeNull ( String )Writes a JSON name/null value pair in an current object context.truetrue
JSONP:JAVADOC:337JsonGeneratorjakarta.json.stream.JsonGenerator.writeNullWrites a JSON null value within the current array, field or root context.truetrue
JSONP:JAVADOC:339JsonGeneratorjakarta.json.stream.JsonGenerator.writeStartArrayWrites the JSON start array character. It starts a new child array context within which JSON values can be written to the array. This method is valid only in an array context, field context or in no context (when a context is not yet started). This method can only be called once in no context.truetrue
JSONP:JAVADOC:340JsonGeneratorjakarta.json.stream.JsonGenerator.writeStartArray ( String )Writes the JSON name/start array character pair with in the current object context. It starts a new child array context within which JSON values can be written to the array.truetrue
JSONP:JAVADOC:341JsonGeneratorjakarta.json.stream.JsonGenerator.writeStartObjectWrites the JSON start object character. It starts a new child object context within which JSON name/value pairs can be written to the object. This method is valid only in an array context, field context or in no context (when a context is not yet started). This method can only be called once in no context.truetrue
JSONP:JAVADOC:342JsonGeneratorjakarta.json.stream.JsonGenerator.writeStartObject ( String )Writes the JSON name/start object character pair in the current object context. It starts a new child object context within which JSON name/value pairs can be written to the object.truetrue
JSONP:JAVADOC:375booleanjakarta.json.stream.JsonParser.hasNextReturns true if there are more parsing states. This method returns false if the parser reaches the end of the JSON text.truetrue
JSONP:JAVADOC:376Eventjakarta.json.stream.JsonParser.nextReturns the event for the next parsing state.truetrue
JSONP:JAVADOC:383CharSequencejakarta.json.JsonString.getCharsReturns the char sequence for the JSON String valuetruetrue
JSONP:JAVADOC:400JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( JsonObjectBuilder )Adds a JsonObject from an object builder to the array.truetrue
JSONP:JAVADOC:401JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( JsonArrayBuilder )Adds a JsonArray from an array builder to the array.truetrue
JSONP:JAVADOC:402JsonArrayjakarta.json.JsonArrayBuilder.buildReturns the current array.truetrue
JSONP:JAVADOC:403JsonArrayBuilderjakarta.json.Json.createArrayBuilderCreates a JSON array buildertruetrue
JSONP:JAVADOC:404JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , JsonObjectBuilder )Adds a name/JsonObject pair to the JSON object associated with this object builder. The value JsonObject is built from the specified object builder. If the object contains a mapping for the specified name, this method replaces the old value with the JsonObject from the specified object builder.truetrue
JSONP:JAVADOC:406JsonObjectBuilderjakarta.json.JsonObjectBuilder.add ( String , JsonArrayBuilder )Adds a name/JsonArray pair to the JSON object associated with this object builder. The value JsonArray is built from the specified array builder. If the object contains a mapping for the specified name, this method replaces the old value with the JsonArray from the specified array builder.truetrue
JSONP:JAVADOC:408JsonObjectjakarta.json.JsonObjectBuilder.buildReturns the JSON object associated with this object builder. The iteration order for the JsonObject is based on the order in which name/value pairs are added to the object using this builder.truetrue
JSONP:JAVADOC:409JsonObjectBuilderjakarta.json.Json.createObjectBuilderCreates a JSON object buildertruetrue
JSONP:JAVADOC:416JsonGeneratorFactoryjakarta.json.Json.createGeneratorFactory ( Map )Creates a generator factory for creating JsonGenerator objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:417JsonParserFactoryjakarta.json.Json.createParserFactory ( Map )Creates a parser factory for creating JsonParser objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:419JsonReaderjakarta.json.JsonReaderFactory.createReader ( Reader )Creates a JSON reader from a character stream. The reader is configured with the factory configuration.truetrue
JSONP:JAVADOC:420JsonReaderjakarta.json.JsonReaderFactory.createReader ( InputStream , Charset )Creates a JSON reader from a byte stream. The bytes of the stream are decoded to characters using the specified charset. The reader is configured with the factory configuration.truetrue
JSONP:JAVADOC:422JsonWriterjakarta.json.JsonWriterFactory.createWriter ( Writer )Creates a JSON writer to write a JSON JsonObject object or JsonArray array structure to the specified character stream. The writer is configured with the factory configuration.truetrue
JSONP:JAVADOC:423JsonWriterjakarta.json.JsonWriterFactory.createWriter ( OutputStream )Creates a JSON writer to write a JSON JsonObject object or JsonArray array structure to the specified byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding. The writer is configured with the factory configuration.truetrue
JSONP:JAVADOC:424JsonWriterjakarta.json.JsonWriterFactory.createWriter ( OutputStream , Charset )Creates a JSON writer to write a JSON JsonObject object or JsonArray array structure to the specified byte stream. Characters written to the stream are encoded into bytes using the specified charset. The writer is configured with the factory configuration.truetrue
JSONP:JAVADOC:425JsonGeneratorFactoryjakarta.json.spi.JsonProvider.createGeneratorFactory ( Map )Creates a generator factory for creating JsonGenerator instances. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:426JsonParserFactoryjakarta.json.spi.JsonProvider.createParserFactory ( Map )Creates a parser factory for creating JsonParser instances. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:427Mapjakarta.json.stream.JsonGeneratorFactory.getConfigInUseReturns a read-only map of supported provider specific configuration properties that are used to configure the JSON generators. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.truetrue
JSONP:JAVADOC:428Mapjakarta.json.stream.JsonParserFactory.getConfigInUseReturns a read-only map of supported provider specific configuration properties that are used to configure the JSON parsers. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.truetrue
JSONP:JAVADOC:429JsonReaderjakarta.json.JsonReaderFactory.createReader ( InputStream )Creates a JSON reader from a byte stream. The character encoding of the stream is determined as described in RFC 7159. The reader is configured with the factory configuration.truetrue
JSONP:JAVADOC:430booleanjakarta.json.JsonArray.getBoolean ( int )Returns the boolean value at the specified position. If the value at the specified position is JsonValue.TRUE this method returns true. If the value at the specified position is JsonValue.FALSE this method returns false.truetrue
JSONP:JAVADOC:433booleanjakarta.json.JsonArray.getBoolean ( int , boolean )Returns the boolean value at the specified position. If the value at the specified position is JsonValue.TRUE this method returns true. If the value at the specified position is JsonValue.FALSE this method returns false. Otherwise this method returns the specified default value.truetrue
JSONP:JAVADOC:434intjakarta.json.JsonArray.getInt ( int , int )Returns the int value of the JsonNumber at the specified position. If the value at that position is a JsonNumber, this method returns jakarta.json.JsonNumber#intValue(). Otherwise this method returns the specified default value.truetrue
JSONP:JAVADOC:435Stringjakarta.json.JsonArray.getString ( int , String )Returns the String value of JsonString at the specified position in this JSON array values. If JsonString is found, its jakarta.json.JsonString#getString() is returned. Otherwise, the specified default value is returned.truetrue
JSONP:JAVADOC:436booleanjakarta.json.JsonObject.getBoolean ( String )Returns the boolean value of the associated mapping for the specified name. If the associated mapping is JsonValue.TRUE, then returns true. If the associated mapping is JsonValue.FALSE, then returns false.truetrue
JSONP:JAVADOC:439booleanjakarta.json.JsonObject.getBoolean ( String , boolean )Returns the boolean value of the associated mapping for the specified name. If the associated mapping is JsonValue.TRUE, then returns true. If the associated mapping is JsonValue.FALSE, then returns false. Otherwise, the specified default value is returned.truetrue
JSONP:JAVADOC:441intjakarta.json.JsonObject.getInt ( String , int )Returns the int value of the associated JsonNumber mapping for the specified name. If JsonNumber is found, then its jakarta.json.JsonNumber#intValue() is returned. Otherwise, the specified default value is returned.truetrue
JSONP:JAVADOC:443Stringjakarta.json.JsonObject.getString ( String , String )Returns the string value of the associated JsonString mapping for the specified name. If JsonString is found, then its jakarta.json.JsonString#getString() is returned. Otherwise, the specified default value is returned.truetrue
JSONP:JAVADOC:445JsonBuilderFactoryjakarta.json.Json.createBuilderFactory ( Map )Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:449JsonReaderFactoryjakarta.json.Json.createReaderFactory ( Map )Creates a reader factory for creating JsonReader objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:452JsonWriterFactoryjakarta.json.Json.createWriterFactory ( Map )Creates a writer factory for creating JsonWriter objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:453JsonArrayBuilderjakarta.json.JsonBuilderFactory.createArrayBuilderCreates a JsonArrayBuilder instance that is used to build JsonArraytruetrue
JSONP:JAVADOC:454JsonObjectBuilderjakarta.json.JsonBuilderFactory.createObjectBuilderCreates a JsonObjectBuilder instance that is used to build JsonObject.truetrue
JSONP:JAVADOC:455Mapjakarta.json.JsonBuilderFactory.getConfigInUseReturns read-only map of supported provider specific configuration properties that are used to configure the created JSON builders. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.truetrue
JSONP:JAVADOC:459Mapjakarta.json.JsonReaderFactory.getConfigInUseReturns read-only map of supported provider specific configuration properties that are used to configure the created JSON readers. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.truetrue
JSONP:JAVADOC:463Mapjakarta.json.JsonWriterFactory.getConfigInUseReturns read-only map of supported provider specific configuration properties that are used to configure the created JSON writer objects. If there are any specified configuration properties that are not supported by the provider, they won't be part of the returned map.truetrue
JSONP:JAVADOC:464JsonArrayBuilderjakarta.json.spi.JsonProvider.createArrayBuilderCreates a JSON array builder.truetrue
JSONP:JAVADOC:465JsonBuilderFactoryjakarta.json.spi.JsonProvider.createBuilderFactory ( Map )Creates a builder factory for creating JsonArrayBuilder and JsonObjectBuilder objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:466JsonObjectBuilderjakarta.json.spi.JsonProvider.createObjectBuilderCreates a JSON object builder.truetrue
JSONP:JAVADOC:467JsonReaderjakarta.json.spi.JsonProvider.createReader ( Reader )Creates a JSON reader from a character stream.truetrue
JSONP:JAVADOC:468JsonReaderjakarta.json.spi.JsonProvider.createReader ( InputStream )Creates a JSON reader from a byte stream. The character encoding of the stream is determined as described in RFC 7159.truetrue
JSONP:JAVADOC:469JsonReaderFactoryjakarta.json.spi.JsonProvider.createReaderFactory ( Map )Creates a reader factory for creating JsonReader objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:470JsonWriterjakarta.json.spi.JsonProvider.createWriter ( Writer )Creates a JSON writer to write a JSON JsonObject object or JsonArray array structure to the specified character stream.truetrue
JSONP:JAVADOC:471JsonWriterjakarta.json.spi.JsonProvider.createWriter ( OutputStream )Creates a JSON writer to write a JSON JsonObject object or JsonArray array structure to the specified byte stream. Characters written to the stream are encoded into bytes using UTF-8 encoding.truetrue
JSONP:JAVADOC:472JsonWriterFactoryjakarta.json.spi.JsonProvider.createWriterFactory ( Map )Creates a writer factory for creating JsonWriter objects. The factory is configured with the specified map of provider specific configuration properties. Provider implementations should ignore any unsupported configuration properties specified in the map.truetrue
JSONP:JAVADOC:474longjakarta.json.stream.JsonLocation.getColumnNumberReturn the column number (starts with 1 for the first column) for the current JSON event in the input source.truetrue
JSONP:JAVADOC:475longjakarta.json.stream.JsonLocation.getLineNumberReturn the line number (starts with 1 for the first line) for the current JSON event in the input source.truetrue
JSONP:JAVADOC:476longjakarta.json.stream.JsonLocation.getStreamOffsetReturn the stream offset into the input source this location is pointing to. If the input source is a file or a byte stream then this is the byte offset into that stream, but if the input source is a character media then the offset is the character offset. Returns -1 if there is no offset available.truetrue
JSONP:JAVADOC:477JsonLocationjakarta.json.stream.JsonParser.getLocationReturn the location that corresponds to the parser's current state in the JSON input source. The location information is only valid in the current parser state (or until the parser is advanced to a next state).truetrue
JSONP:JAVADOC:478JsonLocationjakarta.json.stream.JsonParsingException.getLocationReturn the location of the incorrect JSON.truetrue
JSONP:JAVADOC:481Listjakarta.json.JsonArray.getValuesAs ( Class )Returns a list view of the specified type for the array. This method does not verify if there is a value of wrong type in the array. Providing this typesafe view dynamically may cause a program fail with a ClassCastException, if there is a value of wrong type in this array. Unfortunately, the exception can occur at any time after this method returns.truetrue
JSONP:JAVADOC:490JsonArrayjakarta.json.JsonArray.getJsonArray ( int )Returns the array value at the specified position in this array. This is a convenience method for (JsonArray)get(index).truetrue
JSONP:JAVADOC:493JsonNumberjakarta.json.JsonArray.getJsonNumber ( int )Returns the number value at the specified position in this array. This is a convenience method for (JsonNumber)get(index).truetrue
JSONP:JAVADOC:496JsonObjectjakarta.json.JsonArray.getJsonObject ( int )Returns the object value at the specified position in this array. This is a convenience method for (JsonObject)get(index).truetrue
JSONP:JAVADOC:499JsonStringjakarta.json.JsonArray.getJsonString ( int )Returns the string value at ths specified position in this array. This is a convenience method for (JsonString)get(index).truetrue
JSONP:JAVADOC:506booleanjakarta.json.JsonArray.isNull ( int )Returns true if the value at the specified location in this array is JsonValue.NULL.truetrue
JSONP:JAVADOC:527JsonArrayjakarta.json.JsonObject.getJsonArray ( String )Returns the array value to which the specified name is mapped. This is a convenience method for (JsonArray)get(name) to get the value.truetrue
JSONP:JAVADOC:529JsonNumberjakarta.json.JsonObject.getJsonNumber ( String )Returns the number value to which the specified name is mapped. This is a convenience method for (JsonNumber)get(name) to get the value.truetrue
JSONP:JAVADOC:531JsonObjectjakarta.json.JsonObject.getJsonObject ( String )Returns the object value to which the specified name is mapped. This is a convenience method for (JsonObject)get(name) to get the value.truetrue
JSONP:JAVADOC:533JsonStringjakarta.json.JsonObject.getJsonString ( String )Returns the string value to which the specified name is mapped. This is a convenience method for (JsonString)get(name) to get the value.truetrue
JSONP:JAVADOC:539booleanjakarta.json.JsonObject.isNull ( String )Returns true if the associated value for the specified name is JsonValue.NULL.truetrue
JSONP:JAVADOC:572JsonArrayBuilderjakarta.json.Json.createArrayBuilder ( JsonArray )Creates a JSON array builder, initialized with the specified arraytruetrue
JSONP:JAVADOC:573JsonArrayBuilderjakarta.json.Json.createArrayBuilder ( Collection )Creates a JSON array builder, initialized with the specified arraytruetrue
JSONP:JAVADOC:574JsonPatchjakarta.json.Json.createDiff ( JsonStructure , JsonStructure )Generates a JSON Patch (RFC 6902) from the source and target JsonStructure. The generated JSON Patch need not be unique.truetrue
JSONP:JAVADOC:575JsonMergePatchjakarta.json.Json.createMergeDiff ( JsonValue , JsonValue )Generates a JSON Merge Patch (RFC 7396) from the source and target JsonValues which when applied to the source, yields the target.truetrue
JSONP:JAVADOC:576JsonMergePatchjakarta.json.Json.createMergePatch ( JsonValue )Creates JSON Merge Patch (RFC 7396) from specified JsonValue.truetrue
JSONP:JAVADOC:577JsonObjectBuilderjakarta.json.Json.createObjectBuilder ( JsonObject )Creates a JSON object builder, initialized with the specified object.truetrue
JSONP:JAVADOC:578JsonObjectBuilderjakarta.json.Json.createObjectBuilder ( Map )Creates a JSON object builder, initialized with the specified object.truetrue
JSONP:JAVADOC:579JsonPatchjakarta.json.Json.createPatch ( JsonArray )Creates a JSON Patch (RFC 6902) from the specified operations.truetrue
JSONP:JAVADOC:580JsonPatchBuilderjakarta.json.Json.createPatchBuilderCreates a JSON Patch builder (RFC 6902).truetrue
JSONP:JAVADOC:581JsonPatchBuilderjakarta.json.Json.createPatchBuilder ( JsonArray )Creates a JSON Patch builder (RFC 6902), initialized with the specified operations.truetrue
JSONP:JAVADOC:582JsonPointerjakarta.json.Json.createPointer ( String )Creates JSON Pointer (RFC 6901) from given jsonPointer string. An empty jsonPointer string defines a reference to the target itself. If the jsonPointer string is non-empty, it must be a sequence of ‘/’ prefixed tokens.truetrue
JSONP:JAVADOC:583JsonStringjakarta.json.Json.createValue ( String )Creates a JsonString.truetrue
JSONP:JAVADOC:584JsonNumberjakarta.json.Json.createValue ( int )Creates a JsonNumber.truetrue
JSONP:JAVADOC:585JsonNumberjakarta.json.Json.createValue ( long )Creates a JsonNumber.truetrue
JSONP:JAVADOC:586JsonNumberjakarta.json.Json.createValue ( double )Creates a JsonNumber.truetrue
JSONP:JAVADOC:587JsonNumberjakarta.json.Json.createValue ( BigDecimal )Creates a JsonNumber.truetrue
JSONP:JAVADOC:588JsonNumberjakarta.json.Json.createValue ( BigInteger )Creates a JsonNumber.truetrue
JSONP:JAVADOC:589Listjakarta.json.JsonArray.getValuesAs ( Function )Returns a list view for the array. The value and the type of the elements in the list is specified by the func argument. This method can be used to obtain a list of the unwrapped types, such as List strings = ary1.getValuesAs(JsonString::getString); List ints = ary2.getValuesAs(JsonNumber::intValue); or a list of simple projections, such as List stringsizes = ary1.getValueAs((JsonString v)->v.getString().length();truetrue
JSONP:JAVADOC:590JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , JsonValue )Inserts a value to the array at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:591JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , String )Adds a value to the array as a JsonString at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:592JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , BigDecimal )Adds a value to the array as a JsonNumber at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:593JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , BigInteger )Adds a value to the array as a JsonNumber at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:594JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , int )Adds a value to the array as a JsonNumber at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:595JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , long )Adds a value to the array as a JsonNumber at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:596JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , double )Adds a value to the array as a JsonNumber at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:597JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , boolean )Adds a JsonValue#TRUE or JsonValue#FALSE value to the array at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:598JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , JsonObjectBuilder )Adds a JsonObject from an object builder to the array at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:599JsonArrayBuilderjakarta.json.JsonArrayBuilder.add ( int , JsonArrayBuilder )Adds a JsonArray from an array builder to the array at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:600JsonArrayBuilderjakarta.json.JsonArrayBuilder.addAll ( JsonArrayBuilder )Adds all elements of the array in the specified array builder to the array.truetrue
JSONP:JAVADOC:601JsonArrayBuilderjakarta.json.JsonArrayBuilder.addNull ( int )Adds a JsonValue#NULL value to the array at the specified position. Shifts the value currently at that position (if any) and any subsequent values to the right (adds one to their indices). Index starts with 0.truetrue
JSONP:JAVADOC:602JsonArrayBuilderjakarta.json.JsonArrayBuilder.remove ( int )Remove the value in the array at the specified position. Shift any subsequent values to the left (subtracts one from their indices.truetrue
JSONP:JAVADOC:603JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , JsonValue )Replaces a value in the array with the specified value at the specified position.truetrue
JSONP:JAVADOC:604JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , String )Replaces a value in the array with the specified value as a JsonString at the specified position.truetrue
JSONP:JAVADOC:605JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , BigDecimal )Replaces a value in the array with the specified value as a JsonNumber at the specified position.truetrue
JSONP:JAVADOC:606JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , BigInteger )Replaces a value in the array with the specified value as a JsonNumber at the specified position.truetrue
JSONP:JAVADOC:607JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , int )Replaces a value in the array with the specified value as a JsonNumber at the specified position.truetrue
JSONP:JAVADOC:608JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , long )Replaces a value in the array with the specified value as a JsonNumber at the specified position.truetrue
JSONP:JAVADOC:609JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , double )Replaces a value in the array with the specified value as a JsonNumber at the specified position.truetrue
JSONP:JAVADOC:610JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , boolean )Replaces a value in the array with a JsonValue#TRUE or JsonValue#FALSE value at the specified position.truetrue
JSONP:JAVADOC:611JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , JsonObjectBuilder )Replaces a value in the array with the specified value as a JsonObject from an object builder at the specified position.truetrue
JSONP:JAVADOC:612JsonArrayBuilderjakarta.json.JsonArrayBuilder.set ( int , JsonArrayBuilder )Replaces a value in the array with the specified value as a JsonArray from an array builder at the specified position.truetrue
JSONP:JAVADOC:613JsonArrayBuilderjakarta.json.JsonArrayBuilder.setNull ( int )Replaces a value in the array with a JsonValue#NULL value at the specified position.truetrue
JSONP:JAVADOC:614JsonArrayBuilderjakarta.json.JsonBuilderFactory.createArrayBuilder ( JsonArray )Creates a JsonArrayBuilder instance, initialized with an array.truetrue
JSONP:JAVADOC:615JsonObjectBuilderjakarta.json.JsonBuilderFactory.createObjectBuilder ( JsonObject )Creates a JsonObjectBuilder instance, initialized with an object.truetrue
JSONP:JAVADOC:616JsonValuejakarta.json.JsonMergePatch.apply ( JsonValue )Applies the JSON Merge Patch to the specified target. The target is not modified by the patch.truetrue
JSONP:JAVADOC:617JsonValuejakarta.json.JsonMergePatch.toJsonValueReturns the JsonMergePatch as JsonValue.truetrue
JSONP:JAVADOC:618JsonObjectBuilderjakarta.json.JsonObjectBuilder.addAll ( JsonObjectBuilder )Adds all name/value pairs in the JSON object associated with the specified object builder to the JSON object associated with this object builder. The newly added name/value pair will replace any existing name/value pair with the same name.truetrue
JSONP:JAVADOC:619JsonObjectBuilderjakarta.json.JsonObjectBuilder.remove ( String )Remove the name/value pair from the JSON object associated with this object builder if it is present.truetrue
JSONP:JAVADOC:620JsonStructurejakarta.json.JsonPatch.apply ( JsonStructure )Applies the patch operations to the specified target. The target is not modified by the patch.truetrue
JSONP:JAVADOC:621JsonArrayjakarta.json.JsonPatch.toJsonArrayReturns the JsonPatch as JsonArray.truetrue
JSONP:JAVADOC:622Operationjakarta.json.JsonPatch.Operation.fromOperationName ( String )Returns the enum constant with the specified name.truetrue
JSONP:JAVADOC:623Stringjakarta.json.JsonPatch.Operation.operationNameReturns enum constant name as lower case string.truetrue
JSONP:JAVADOC:624Operationjakarta.json.JsonPatch.Operation.valueOf ( String )truetrue
JSONP:JAVADOC:625Operation[]jakarta.json.JsonPatch.Operation.valuestruetrue
JSONP:JAVADOC:626JsonPatchBuilderjakarta.json.JsonPatchBuilder.add ( String , JsonValue )Adds an “add” JSON Patch operation.truetrue
JSONP:JAVADOC:627JsonPatchBuilderjakarta.json.JsonPatchBuilder.add ( String , String )Adds an “add” JSON Patch operation.truetrue
JSONP:JAVADOC:628JsonPatchBuilderjakarta.json.JsonPatchBuilder.add ( String , int )Adds an “add” JSON Patch operation.truetrue
JSONP:JAVADOC:629JsonPatchBuilderjakarta.json.JsonPatchBuilder.add ( String , boolean )Adds an “add” JSON Patch operation.truetrue
JSONP:JAVADOC:630JsonPatchjakarta.json.JsonPatchBuilder.buildReturns the JSON Patch.truetrue
JSONP:JAVADOC:631JsonPatchBuilderjakarta.json.JsonPatchBuilder.copy ( String , String )Adds a “copy” JSON Patch operation.truetrue
JSONP:JAVADOC:632JsonPatchBuilderjakarta.json.JsonPatchBuilder.move ( String , String )Adds a “move” JSON Patch operation.truetrue
JSONP:JAVADOC:633JsonPatchBuilderjakarta.json.JsonPatchBuilder.remove ( String )Adds a “remove” JSON Patch operation.truetrue
JSONP:JAVADOC:634JsonPatchBuilderjakarta.json.JsonPatchBuilder.replace ( String , JsonValue )Adds a “replace” JSON Patch operation.truetrue
JSONP:JAVADOC:635JsonPatchBuilderjakarta.json.JsonPatchBuilder.replace ( String , String )Adds a “replace” JSON Patch operation.truetrue
JSONP:JAVADOC:636JsonPatchBuilderjakarta.json.JsonPatchBuilder.replace ( String , int )Adds a “replace” JSON Patch operation.truetrue
JSONP:JAVADOC:637JsonPatchBuilderjakarta.json.JsonPatchBuilder.replace ( String , boolean )Adds a “replace” JSON Patch operation.truetrue
JSONP:JAVADOC:638JsonPatchBuilderjakarta.json.JsonPatchBuilder.test ( String , JsonValue )Adds a “test” JSON Patch operation.truetrue
JSONP:JAVADOC:639JsonPatchBuilderjakarta.json.JsonPatchBuilder.test ( String , String )Adds a “test” JSON Patch operation.truetrue
JSONP:JAVADOC:640JsonPatchBuilderjakarta.json.JsonPatchBuilder.test ( String , int )Adds a “test” JSON Patch operation.truetrue
JSONP:JAVADOC:641JsonPatchBuilderjakarta.json.JsonPatchBuilder.test ( String , boolean )Adds a “test” JSON Patch operation.truetrue
JSONP:JAVADOC:642JsonStructurejakarta.json.JsonPointer.add ( JsonStructure , JsonValue )Adds or replaces a value at the referenced location in the specified target with the specified value. If the reference is the target (empty JSON Pointer string), the specified value, which must be the same type as specified target, is returned. If the reference is an array element, the specified value is inserted into the array, at the referenced index. The value currently at that location, and any subsequent values, are shifted to the right (adds one to the indices). Index starts with 0. If the reference is specified with a “-”, or if the index is equal to the size of the array, the value is appended to the array. If the reference is a name/value pair of a JsonObject, and the referenced value exists, the value is replaced by the specified value. If the value does not exist, a new name/value pair is added to the object.truetrue
JSONP:JAVADOC:643JsonValuejakarta.json.JsonPointer.getValue ( JsonStructure )Returns the value at the referenced location in the specified target.truetrue
JSONP:JAVADOC:644JsonStructurejakarta.json.JsonPointer.remove ( JsonStructure )Removes the value at the reference location in the specified target.truetrue
JSONP:JAVADOC:645JsonStructurejakarta.json.JsonPointer.replace ( JsonStructure , JsonValue )Replaces the value at the referenced location in the specified target with the specified value.truetrue
JSONP:JAVADOC:646JsonValuejakarta.json.JsonReader.readValueReturns a JSON value that is represented in the input source. This method needs to be called only once for a reader instance.truetrue
JSONP:JAVADOC:647JsonValuejakarta.json.JsonStructure.getValue ( String )Get the value referenced by the provided JSON Pointer in the JsonStructure.truetrue
JSONP:JAVADOC:648JsonArrayjakarta.json.JsonValue.asJsonArrayReturn the JsonValue as a JsonArraytruetrue
JSONP:JAVADOC:649JsonObjectjakarta.json.JsonValue.asJsonObjectReturn the JsonValue as a JsonObjecttruetrue
JSONP:JAVADOC:650voidjakarta.json.JsonWriter.write ( JsonValue )Writes the specified JsonValue to the output source. method needs to be called only once for a write instance.truetrue
JSONP:JAVADOC:651JsonArrayBuilderjakarta.json.spi.JsonProvider.createArrayBuilder ( JsonArray )Creates a JSON array builder, initialized with the specified array.truetrue
JSONP:JAVADOC:652JsonArrayBuilderjakarta.json.spi.JsonProvider.createArrayBuilder ( Collection )Creates a JSON array builder, initialized with the specified collection.truetrue
JSONP:JAVADOC:653JsonPatchjakarta.json.spi.JsonProvider.createDiff ( JsonStructure , JsonStructure )Generates a JSON Patch (RFC 6902) from the source and target JsonStructure. The generated JSON Patch need not be unique.truetrue
JSONP:JAVADOC:654JsonMergePatchjakarta.json.spi.JsonProvider.createMergeDiff ( JsonValue , JsonValue )Generates a JSON Merge Patch (RFC 7396) from the source and target JsonValues which when applied to the source, yields the target.truetrue
JSONP:JAVADOC:655JsonMergePatchjakarta.json.spi.JsonProvider.createMergePatch ( JsonValue )Creates JSON Merge Patch (RFC 7396) from specified JsonValue.truetrue
JSONP:JAVADOC:656JsonObjectBuilderjakarta.json.spi.JsonProvider.createObjectBuilder ( JsonObject )Creates a JSON object builder, initialized with the specified object.truetrue
JSONP:JAVADOC:657JsonObjectBuilderjakarta.json.spi.JsonProvider.createObjectBuilder ( Map )Creates a JSON object builder, initialized with the specified Map.truetrue
JSONP:JAVADOC:658JsonPatchjakarta.json.spi.JsonProvider.createPatch ( JsonArray )Creates a JSON Patch (RFC 6902) from the specified operations.truetrue
JSONP:JAVADOC:659JsonPatchBuilderjakarta.json.spi.JsonProvider.createPatchBuilderCreates a JSON Patch builder (RFC 6902).truetrue
JSONP:JAVADOC:660JsonPatchBuilderjakarta.json.spi.JsonProvider.createPatchBuilder ( JsonArray )Creates a JSON Patch builder (RFC 6902), initialized with the specified operations.truetrue
JSONP:JAVADOC:661JsonPointerjakarta.json.spi.JsonProvider.createPointer ( String )Creates JSON Pointer (RFC 6901) from given jsonPointer string. An empty jsonPointer string defines a reference to the target itself. If the jsonPointer string is non-empty, it must be a sequence of ‘/’ prefixed tokens.truetrue
JSONP:JAVADOC:662JsonStringjakarta.json.spi.JsonProvider.createValue ( String )Creates a JsonString.truetrue
JSONP:JAVADOC:663JsonNumberjakarta.json.spi.JsonProvider.createValue ( int )Creates a JsonNumber.truetrue
JSONP:JAVADOC:664JsonNumberjakarta.json.spi.JsonProvider.createValue ( long )Creates a JsonNumber.truetrue
JSONP:JAVADOC:665JsonNumberjakarta.json.spi.JsonProvider.createValue ( double )Creates a JsonNumber.truetrue
JSONP:JAVADOC:666JsonNumberjakarta.json.spi.JsonProvider.createValue ( BigDecimal )Creates a JsonNumber.truetrue
JSONP:JAVADOC:667JsonNumberjakarta.json.spi.JsonProvider.createValue ( BigInteger )Creates a JsonNumber.truetrue
JSONP:JAVADOC:668Collectorjakarta.json.stream.JsonCollectors.groupingBy ( Function , Collector )Constructs a java.util.stream.Collector that implements a “group by” operation on the input JsonValue elements. A classifier function maps the input JsonValues to keys, and the JsonValues are partitioned into groups according to the value of the key. A reduction operation is performed on the JsonValues in each group, using the downstream Collector. For each group, the key and the results of the reduction operation become the name/value pairs of the resultant JsonObject.truetrue
JSONP:JAVADOC:669Collectorjakarta.json.stream.JsonCollectors.groupingBy ( Function )Constructs a java.util.stream.Collector that implements a “group by” operation on the input JsonValue elements. A classifier function maps the input JsonValues to keys, and the JsonValues are partitioned into groups according to the value of the key. The JsonValues in each group are added to a JsonArray. The key and the JsonArray in each group becomes the name/value pair of the resultant JsonObject.truetrue
JSONP:JAVADOC:670Collectorjakarta.json.stream.JsonCollectors.toJsonArrayConstructs a java.util.stream.Collector that accumulates the input JsonValue elements into a JsonArray.truetrue
JSONP:JAVADOC:671Collectorjakarta.json.stream.JsonCollectors.toJsonObject ( Function , Function )Constructs a java.util.stream.Collector that accumulates the input JsonValue elements into a JsonObject. The name/value pairs of the JsonObject are computed by applying the provided mapping functions.truetrue
JSONP:JAVADOC:672JsonGeneratorjakarta.json.stream.JsonGenerator.writeKey ( String )Writes the JSON name with a colon. It starts a field context, in which valid options are writing a value, starting an object or an array. Writing value closes field context, if object or array is started after field name, field context will be closed after object/array close.truetrue
JSONP:JAVADOC:673JsonArrayjakarta.json.stream.JsonParser.getArrayReturns a JsonArray and advance the parser to the the corresponding END_ARRAY.truetrue
JSONP:JAVADOC:674Streamjakarta.json.stream.JsonParser.getArrayStreamReturns a stream of the JsonArray elements. The parser state must be START_ARRAY. The elements are read lazily, on an as-needed basis, as required by the stream operations. If the stream operations do not consume all of the array elements, skipArray can be used to skip the unprocessed array elements.truetrue
JSONP:JAVADOC:675JsonObjectjakarta.json.stream.JsonParser.getObjectReturns a JsonObject and advances the parser to the corresponding END_OBJECT.truetrue
JSONP:JAVADOC:676Streamjakarta.json.stream.JsonParser.getObjectStreamReturns a stream of the JsonObject‘s name/value pairs. The parser state must be START_OBJECT. The name/value pairs are read lazily, on an as-needed basis, as required by the stream operations. If the stream operations do not consume all of the object’s name/value pairs, skipObject can be used to skip the unprocessed elements.truetrue
JSONP:JAVADOC:677JsonValuejakarta.json.stream.JsonParser.getValueReturns a JsonValue at the current parser position. If the parser state is START_ARRAY, the behavior is the same as #getArray. If the parser state is START_OBJECT, the behavior is the same as #getObject. For all other cases, if applicable, the JSON value is read and returned.truetrue
JSONP:JAVADOC:678Streamjakarta.json.stream.JsonParser.getValueStreamReturns a stream of JsonValue from a sequence of JSON values. The values are read lazily, on an as-needed basis, as needed by the stream operations.truetrue
JSONP:JAVADOC:679voidjakarta.json.stream.JsonParser.skipArrayAdvance the parser to END_ARRAY. If the parser is in array context, i.e. it has previously encountered a START_ARRAY without encountering the corresponding END_ARRAY, the parser is advanced to the corresponding END_ARRAY. If the parser is not in any array context, nothing happens.truetrue
JSONP:JAVADOC:680voidjakarta.json.stream.JsonParser.skipObjectAdvance the parser to END_OBJECT. If the parser is in object context, i.e. it has previously encountered a START_OBJECT without encountering the corresponding END_OBJECT, the parser is advanced to the corresponding END_OBJECT. If the parser is not in any object context, nothing happens.truetrue
JSONP:JAVADOC:681enumjakarta.json.JsonConfig.KeyStrategyDefines the different values allowed for KEY_STRATEGY.truetrue
JSONP:JAVADOC:682JsonNumberjakarta.json.Json.createValue(Number value)Creates a JsonNumber.truetrue
JSONP:JAVADOC:683Eventjakarta.json.stream.JsonParser.currentEventThe event for the current parsing state.truetrue